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TTSS  RREEPPOORRTTSSEERRVVEERR  
TS ReportServer takes output from Report-IV on the host and presents it graphically at the 
workstation. It is fully integrated with VIP but does not require that the graphical presentation be 
installed or enabled, meaning it will also work when running your application in character mode. 
You can also use TS ReportServer with Gateway for Windows. 
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PPAATTHH  DDEEFFIINNIITTIIOONNSS  AANNDD  CCOONNVVEENNTTIIOONNSS  
The paths noted in this manual vary depending upon the operating system. 

vip-data-path is used to indicate the path where files requiring read and write access are located. 

• On Windows 10/Windows 11/Windows Server 2016/Windows Server 2019/Windows Server 2022 the 
required path is C:\ProgramData\Thoroughbred Software\TSI. 

vip-user-path is used to indicate the path where user specific files requiring read and write access are 
located. 

• On Windows 10/Windows 11/Windows Server 2016/Windows Server 2019/Windows Server 2022 the 
required path is C:\Users\tbred2\AppData\Roaming\Thoroughbred Software. 

vip-program-path is used to indicate the path where executable and some dll files are located. 

• On all Window platforms the default path is C:\Program Files\TSI\Bin. 

vip-system-path is used to indicate the path where Thoroughbred ini files and other system files that 
require write access are located. 

• On Windows 10/Windows 11/Windows Server 2016/Windows Server 2019/Windows Server 2022 the 
required path is C:\ProgramData\Thoroughbred Software. 

• On other Window platforms this path may vary, typically it is C:\Documents and Settings\All 
Users\Application Data\Thoroughbred Software. 
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SSEETTUUPP  
The Thoroughbred Environment includes the RPSERV printer table. From the System 
Administration menu select Printer Assignment. For more information see the Dictionary-IV 
Administrator Guide. Assign any printer device (i.e. RS, LP, P1) to the RPSERV printer table. 
The recommended printer device is RS. You will then need to modify your IPLINPUT file to 
include this printer device. 

For more information see the Thoroughbred Basic Customization and Tuning Guide. 

IPLINPUT for Windows Basic: 

DEV RS,4,,,,,,NUL 
or 
DEV RS,4,,,,,,file-name 

Where file-name is the name of any text file defined in your Thoroughbred Basic Environment 
for example, basic-install-path\Tbsc\RSText.txt 

IPLINPUT for UNIX: 

DEV RS,4,,,1,,,/dev/null 

For more help on how to use the TS ReportServer 

• Select vip-data-path\Tsi\Bin\Rps.hlp, or 

• Select Help and then select Help Index from the TS ReportServer menu bar. 

For more information see the Thoroughbred Basic Customization and Tuning Guide. 

Creating and Sending Report-IV Output to TS ReportServer 

TS ReportServer is included as a standard output device in the Dictionary-IV printer selection 
prompt: 

 

When TS ReportServer is selected as the output device, the report will automatically be 
displayed by the TS ReportServer on the client. 
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TS ReportServer can display multiple reports. Each report is displayed in a window contained by 
one common TS ReportServer GUI Server window. 

 

Any report displayed by TS ReportServer can be saved locally on the client. By default, the file 
is saved in TS ReportServer format (with the .rpt file extension). For more information on saving 
and opening local report files please see "Save a Report" later in this manual. 
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An application performing CONNECT REPORT can control the output device by pre-setting the 
printer id. This allows the application to send the report output to the TS ReportServer without 
user intervention. 

If the TS ReportServer is available, Query-IV sends all terminal output to the TS ReportServer 
for processing. Your application can duplicate this process. Query-IV uses the following tests to 
determine if the TS ReportServer is available: 

Is the default output set to the terminal? 

FID(0) 

Does the Global variable RPSERV exist? 

CGV("RPSERV") 

Does the Workstation have GUI capabilities? 

#IDVIP.GUI-ON="Y" 

If these tests determine that the TS ReportServer is available set the output device to the Global 
variable RPSERV. 

LET REPORT$[6]=cgv("RPSERV") 

CONNECT Report "report-name" 
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TTSS  RREEPPOORRTTSSEERRVVEERR  WWIINNDDOOWW  
The main TS ReportServer GUI Server window is displayed when TS ReportServer is selected 
as the output device on the host or when you select the TS ReportServer icon on the client from 
the VIP program group. 

 

File 
Open an rps file 
Print Setup to select the printer properties, etc. 
 

 

Recent Files to select from the last files opened. 

Exit TS ReportServer. 
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Options 

Check (display) or uncheck (remove) the Status Bar, Pagebar, and Toolbar from the TS 
ReportServer window. See the graphic above to see where these are located. 

Check Paged Scroll to scroll the last 100 pages of the report history. 

Help 
Access TS ReportServer help. 

Open a Report 

From the TS ReportServer window select the File menu and then select Open. 

 

NOTE: TS ReportServer can only open (display) files that have been saved in .rps format. 
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The .rps files above are sample reports that are stored in vip-user-path\TSI\Reports. Select 
Sample1.rps and the following report appears: 

 

NOTE: The TS ReportServer can handle multiple reports as well as split screen viewing within a 
report. See below. 

Menus 

File 

Open an .rps file located in vip-user-path\TSI\Reports. 

Close the currently highlighted report. 

Save the currently highlighted report. 

Save As an .rps or .txt file. 

Print the currently highlighted report. 

Print Preview of the report before printing. 

Print Setup 
Displays the dialog box below so you can select the printer, paper size, orientation, etc. 
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Recent Files displayed are listed. 

Exit TS ReportServer 

Edit - Select Copy, Find or Select All  

View – Select Zoom In, Zoom Out, or select the Font. 

Options – Select to view any or all of the following: Toolbar, Pagebar, Status Bar or Paged 
Scroll. 

Window – Select to Cascade or Tile the windows. You can also Arrange Icons. This simply 
means that when you minimize a report window, an icon for the report displays at the bottom of 
the window (see below). 
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and you move one of the "icons" (see below). 

 

Select Windows Arrange Icons to place them back at the bottom of the screen (see below). 

 

Help – Select the Help index or find the version number (About). 
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Toolbar 

The Toolbar can be moved using normal Windows procedures. The following buttons are 
available from the Toolbar: 

 Open and Save 

Open – This button allows you to open an .rps file to edit. 

Save – This button allows you to save the file (the first time opened) or to save edits to the 
report. 

NOTE: From the File menu you can save the report as *.rps, or *.txt files. From the Edit menu 
you can copy the report to the clipboard, make changes to the report and save, or exit without 
saving. For more information see Saving a Report. 

 Copy 

Copy – This button allows you to copy the edited file to the clipboard. 

 Print and About 

Print – This button allows you to print the edited file. 

About – This button displays the TS ReportServer version. 

 Font Size and Find 

Font Size – This button allows you to zoom in or out in the report. 

Find – This button allows you to search the file for characters, numbers, or words. 

Split Screen Viewing 

With TS ReportServer you can split reports both vertically and horizontally. Each pane contains 
a set of scroll bars allowing each to be scrolled independently of the other. It supports a total of 
four panes: two vertical split panes and two horizontal split panes. 
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To create two vertical panes 
Grab the little button on top of the vertical scroll bar (see graphic above) and then drag your 
mouse down. 

 

Grab for vertically 
split screen. 

Grab for horizontally 
split screen. 
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You now have two vertical panes that can be scrolled independently. To create a single pane, 
reverse the procedure used to create two panes. 

To create two horizontal panes 
Grab the little button on the left of the horizontal scroll bar (see graphic at the beginning of this 
section) and then drag your mouse to the right. 

 

You now have two horizontal panes that can be scrolled independently. To create a single pane, 
reverse the procedure used to create two panes. 
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To create four panes 
Simply perform the two procedures above and you will have a split screen similar to the one 
below: 

 

The frame can be resized using normal Windows procedure. Grab any side or corner and enlarge 
or decrease the size. 
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Save a Report 

A report can be saved by selecting File menu Save, by closing a report window or by closing the 
main TS ReportServer window. The following message is displayed for the top report displayed 
in the main TS ReportServer window: 

 

Yes – Will save the report prompting for a file name, location, and a file extension.  

No – Will close the report without saving it. 

No to all – Will close the current report without saving and will not prompt you to save when 
closing other report windows. This eliminates the need to respond No for each opened report.  

Cancel – Closes the save dialog and without doing anything. 

TS ReportServer allows you to save a report in two formats. 

Saving as a Thoroughbred Reports file (*.rps) 

• From the File menu select Save. The report file will be saved to the default folder. The 
default folder location is set from the WorkStation Manager Default Directories tab. If none 
is supplied report files will be saved in vip-user-path. For more information, please see the 
WorkStation Manager Manual. 
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• From the File menu select Save As and then you can save the report as a TS ReportServer 
file (.rps) in the folder of your choice. 

Saving in a different format 

From the File menu select Save As and then you can save the report as a text file (txt) in the 
folder of your choice. 

NOTE: TS ReportServer can only display reports that are saved in .rps format. Once a report is 
saved as a text file, TS ReportServer cannot be used to open it. 

Copying to the Clipboard 

From the Edit menu select Copy and then you can Paste the report in any DDE compliant 
application.  
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GGAATTEEWWAAYY  FFOORR  WWIINNDDOOWWSS  
The host program requires a simple communication. Each page uses a single CALL to the 
program RPSCOM. 

Terminate each line on the page with: 

CRLF (CHR(13)+CHR(10)) 

Terminate each page with: 

FF (CHR(12)) 
page-of-data" + CHR(12) 

Prefix the CRLF at the end of each line with a CHR(11) to indicate a heading line. 

CHR(11) + CRLF 

The TS ReportServer displays a dialog status box as each page is received and processed. 
Append the following instruction to the final page of the report: 

"page-of-data-for-last-page" + "[.END.]" 

The TS ReportServer immediately displays the report. It allows complete user manipulation and 
processing of the report, including forward and backward scrolling, printing to a file, and saving 
to a file. 

Example 

The following example illustrates the simplicity of the host programming required to invoke TS 
ReportServer. 

00010 REM &REM& 

00020 BEGIN; 
  DIM M$[5];        
 !Gateway call string 
  LINEEND$=CHR(13)+CHR(10),    !End of 
line indicator 
  HEADLINEEND$=CHR(11)+LINEEND$,  !End of heading 
indicator 
  LAST$="[.END.]"       !Last 
page indicator 
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00100 M$[1]="I4", 
M$[2]="RPS", 
M$[3]="SYSTEM", 
M$[5]="[.LOAD.]"; 
CALL "RPSCOM",M$[ALL]; 
IF M$[0]<>"." 
 GOTO 9000 
ELSE 
 M$[1]="P",      !Define Report Message: 
 M$[5]="**"+      !(1,2)="**" 
  "UTSAMPLE"+     !(3,8)=Report name 
         
 !(11,40)=Report Description 
  "Gateway for Windows Test Report "+ 
  "080"+      !(51,3)=Report 
width 
   "060";      !(54,3)=Number of 
lines/page 
 CALL "RPSCOM",M$[ALL] 

00200 REM PAGE1 

00210 P$="", 
 P$=P$+" HEADING LINE 1 "+HEADLINEEND$, 
 P$=P$+" HEADING LINE 2 "+HEADLINEEND$, 
 P$=P$+"DETAIL LINE 1 "+LINEEND$, 
 P$=P$+"DETAIL LINE 2 "+LINEEND$, 
 P$=P$+"DETAIL LINE N "+LINEEND$, 
 P$=P$+CHR(12); 
 GOSUB 1000 

00220 REM PAGE2 THRU PAGEn 

00230 P$="", 
 P$=P$+" HEADING LINE 1 "+HEADLINEEND$, 
 P$=P$+" HEADING LINE 2 "+HEADLINEEND$, 
 P$=P$+"DETAIL LINE 1 "+LINEEND$, 
 P$=P$+"DETAIL LINE 2 "+LINEEND$, 
 P$=P$+"DETAIL LINE N "+LINEEND$, 
 P$=P$+CHR(12); 
 GOSUB 1000 

00240 REM LAST PAGE 

00250 P$="", 
P$=P$+" HEADING LINE 1 "+HEADLINEEND$, 
 P$=P$+" HEADING LINE 2 "+HEADLINEEND$, 
 P$=P$+"DETAIL LINE 1 "+LINEEND$, 
 P$=P$+"DETAIL LINE 2 "+LINEEND$, 
 P$=P$+"DETAIL LINE N "+LINEEND$, 
 P$=P$+LAST$; 
 GOSUB 1000; 
 GOTO 9000 

01000 M$[5]=P$; 
 CALL "RPSCOM",M$[ALL]; 
 RETURN 

09000 RUN "**" 
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MMUULLTTII--LLAANNGGUUAAGGEE  
For more information about Multi-Language, see the Dialog, Message, and MenuBar Text 
Translations section in the Multi-Language for VIP. 
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